KY HB183 | 2022 | Regular Session

Status

Spectrum: Partisan Bill (Democrat 1-0)
Status: Introduced on January 4 2022 - 25% progression
Action: 2022-01-04 - to Committee on Committees (H)
Pending: House Committee On Committees Committee
Text: Latest bill text (Introduced) [PDF]

Summary

Create a new section of Subtitle 17A of KRS Chapter 304 to require health benefit plans to cover injectable epinephrine devices for persons 18 years of age and under; provide that the coverage shall not be subject to cost-sharing requirements; amend KRS 205.522, 205.6485, 18A.225, and 164.2871 to require Medicaid, KCHIP, the state employee health plan, and self-insured employer group health plans offered by the governing board of a state postsecondary education institution to comply with the 18-and-under injectable epinephrine device coverage requirement; EFFECTIVE January 1, 2023.

Tracking Information

Register now for our free OneVote public service or GAITS Pro trial account and you can begin tracking this and other legislation, all driven by the real-time data of the LegiScan API. Providing tools allowing you to research pending legislation, stay informed with email alerts, content feeds, and share dynamic reports. Use our new PolitiCorps to join with friends and collegaues to monitor & discuss bills through the process.

Monitor Legislation or view this same bill number from multiple sessions or take advantage of our national legislative search.

Title

AN ACT relating to coverage for injectable epinephrine devices.

Sponsors


History

DateChamberAction
2022-01-04Houseto Committee on Committees (H)
2022-01-04Houseintroduced in House

Subjects


Kentucky State Sources


Bill Comments

feedback